Issue
While backing up OneDrive items, the job will complete successfully but your Cirrus logs say completed with a warning: OneDrive was not found.
Summary
When checking your Cirrus backup session logs you may see the following warning.
Warning
Processing OneDrive <Name> completed with warning: OneDrive was not found (ID: <ID>, name: <Name>)
Cause
Veeam will attempt to process Exchange, OneDrive, Sharepoint and teams for each user. This particular warning is letting you know that the end-users Microsoft licence does not include a OneDrive account.
Resolution
For users on the Variable license model, you can omit certain items from users' backup. This is optional: the warning will have no effect on your backups, and you can safely ignore it.
If you are on a Fixed license model you will not be able to alter the backup jobs, as they are automatically configured. You may safely ignore the warning on your backups, as all relevant data will continue to be captured correctly.
References
If you are unsure of how to check your backup session logs, please see the following: View Backup Logs.
Help & Support
If you have followed the steps outlined above and the issue recurs in the next backup cycle, or you need help performing these changes, you can access online help at https://support.cirrusbackup.com.